]> Zhao Yanbai Git Server - minix.git/commitdiff
Do not overwrite vi and ex links by default 22/122/2
authorLionel Sambuc <lionel@minix3.org>
Fri, 16 Nov 2012 16:03:15 +0000 (17:03 +0100)
committerLionel Sambuc <lionel@minix3.org>
Mon, 19 Nov 2012 15:44:38 +0000 (16:44 +0100)
Revert (and document) to the old behaviour of the elvis Makefile.

Change-Id: I800dba23f5c35d4c1676974962806dd824659539

commands/elvis/Makefile

index 8ecabd1e7806618d669e6f54c1301823662b2321..b0f8d85ebc8529e18fd445def8a0ab43c8f155ae 100644 (file)
@@ -15,7 +15,8 @@ CPPFLAGS+= -w -DCRUNCH \
        -DNO_MODELINE -DNO_OPTCOLS -DNO_DIGRAPH -DNO_EXTENSIONS \
        -DNO_ERRLIST -DNO_FKEY -DNO_VISIBLE -DNO_COLOR -DNO_POPUP
 
-# LSC Force usage of local getline
+# LSC Force usage of local getline, this is required here as long as
+# we do not fix elvis.
 CPPFLAGS+= -D__NBSD_LIBC
 
 ###########################################################################
@@ -28,8 +29,16 @@ SRCS.elvis= blk.c cmd1.c cmd2.c ctype.c curses.c cut.c ex.c input.c \
    unix.c vars.c vcmd.c vi.c
 
 BINDIR= /usr/bin
+
+# Do not overwrite vi and ex if they already exist, only install the links
+# as a default fallback in their absence
+.if !exists(${DESTDIR}/${BINDIR}/vi)
 LINKS+= ${BINDIR}/elvis ${BINDIR}/vi
+.endif
+
+.if !exists(${DESTDIR}/${BINDIR}/ex)
 LINKS+= ${BINDIR}/elvis ${BINDIR}/ex
+.endif
 
 MAN.elvis=
 MAN.ctags=