]> Zhao Yanbai Git Server - minix.git/commitdiff
Added getprotobyname.
authorPhilip Homburg <philip@cs.vu.nl>
Wed, 9 Nov 2005 15:42:38 +0000 (15:42 +0000)
committerPhilip Homburg <philip@cs.vu.nl>
Wed, 9 Nov 2005 15:42:38 +0000 (15:42 +0000)
lib/ip/Makefile
lib/ip/getprotoname.c [new file with mode: 0644]

index 1d11556ef34d1ee03a277db9cc4d645f2657b722..64235eb3ff4f6b6a86d6fae27f348f3a5e84f465 100755 (executable)
@@ -27,6 +27,7 @@ libc_OBJECTS  = \
        getpeername.o \
        getproto.o \
        getprotoent.o \
+       getprotoname.o \
        getservent.o \
        getsockname.o \
        getsockopt.o \
diff --git a/lib/ip/getprotoname.c b/lib/ip/getprotoname.c
new file mode 100644 (file)
index 0000000..0832acf
--- /dev/null
@@ -0,0 +1,62 @@
+/*
+ * Copyright (c) 1983, 1993
+ *     The Regents of the University of California.  All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ *    notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ *    notice, this list of conditions and the following disclaimer in the
+ *    documentation and/or other materials provided with the distribution.
+ * 3. All advertising materials mentioning features or use of this software
+ *    must display the following acknowledgement:
+ *     This product includes software developed by the University of
+ *     California, Berkeley and its contributors.
+ * 4. Neither the name of the University nor the names of its contributors
+ *    may be used to endorse or promote products derived from this software
+ *    without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED.  IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ */
+
+#if defined(LIBC_SCCS) && !defined(lint)
+static char sccsid[] = "@(#)getprotoname.c     8.1 (Berkeley) 6/4/93";
+#endif /* LIBC_SCCS and not lint */
+
+#include <netdb.h>
+#include <string.h>
+
+extern int _proto_stayopen;
+
+struct protoent *
+getprotobyname(name)
+       register const char *name;
+{
+       register struct protoent *p;
+       register char **cp;
+
+       setprotoent(_proto_stayopen);
+       while ( (p = getprotoent()) ) {
+               if (strcmp(p->p_name, name) == 0)
+                       break;
+               for (cp = p->p_aliases; *cp != 0; cp++)
+                       if (strcmp(*cp, name) == 0)
+                               goto found;
+       }
+found:
+       if (!_proto_stayopen)
+               endprotoent();
+       return (p);
+}