]> Zhao Yanbai Git Server - minix.git/commitdiff
add -L for future compiler-rt lib location
authorBen Gras <ben@minix3.org>
Thu, 8 Dec 2011 17:07:30 +0000 (18:07 +0100)
committerBen Gras <ben@minix3.org>
Thu, 8 Dec 2011 17:07:57 +0000 (18:07 +0100)
kernel/Makefile
share/mk/minix.service.mk

index 6d89d7c66dfc83f9628833e5184b6716b66b77e9..187d36d2b6f0e8e1ad8c0226dd2ace168965ba6a 100644 (file)
@@ -29,7 +29,7 @@ DPADD+= ${LIBMINLIB}
 .if ${CC} == "gcc"
 LDADD+=        -lgcc -lsys -lgcc -lminc
 .elif ${CC} == "clang"
-LDADD+= -L/usr/pkg/lib -lCompilerRT-Generic -lsys -lCompilerRT-Generic -lminc
+LDADD+= -L/usr/pkg/lib -L/usr/pkg/compiler-rt/lib -lCompilerRT-Generic -lsys -lCompilerRT-Generic -lminc
 DPADD+=        ${LIBC}
 .endif
 .endif
index df50c11ef2b541fcccab4db0548a9d7d233017a2..1fc383cc779022ce0084be6aeedcfeff4369928a 100644 (file)
@@ -6,7 +6,7 @@
 .if ${CC} == "gcc"
 LDADD+= -nodefaultlibs -lgcc -lsys -lgcc -lminc
 .elif ${CC} == "clang"
-LDADD+= -nodefaultlibs -L/usr/pkg/lib -lCompilerRT-Generic -lsys -lCompilerRT-Generic -lminc
+LDADD+= -nodefaultlibs -L/usr/pkg/lib -L/usr/pkg/compiler-rt/lib -lCompilerRT-Generic -lsys -lCompilerRT-Generic -lminc
 .endif
 
 .endif